rangerovers.pub
The only place for a coil spring is up Zebedee's arse.
Member
Joined: Oct 17 2016
Posts: 48

I knew the battery in the my key fob was failing. This morning I had trouble unlocking the car and when I went to do the school run this afternoon it wouldn't at all. Popped into the hardware and grabbed some new batteries but now it won't start at all. I'm getting an engine-disabled, press remote or enter keycode. Unfortunately neither pressing the remote nor entering the EKA is working. I suspect the key's not synced and I'm going to double check the keycode with the dealer, though i'm pretty sure I've used the EKA in the past. Unlocking the driver's door with the key unlocks the bootlid, but nothing else.

I've had the door panel off and it appears that someone has replaced the original latch with the later style one with the extra harness (the car's an M-Reg so it should have the early latch).

There has been a "whirring" noise coming from the driver's latch for the past few weeks when I unlock on the remote.

I've got a multimeter and can test it but the car's parked on a busy road three miles from home so I didn't have time this evening. Before I start on that, any advice?

Member
Joined: Nov 27 2017
Posts: 207

I had a flat battery cause similar when near strong RF signals. Plugged in battery charger and Waited 20 mins entered the EKA code and it started.

I do have one of those small jump packs otherwise make sure the bonnet is fully shut otherwise EKA code will not be accepted.

Member
avatar
Joined: Dec 30 2015
Posts: 3401

See marty's door latch test sheet here https://rangerovers.pub/topic/5-info-front-door-latch-tests and get stuck in with the multimeter. It is going to need the EKA entering somehow. You won't be able to sync the key while it is immobilised, you'll have to wait until you've got the EKA working.

Member
Joined: Oct 17 2016
Posts: 48

I've used Marty's door latch test before on my old P38. Thanks for the reminder about the bonnet though as one of the two catches is sticky and does not always do its job. Will check in the morning.

Member
Joined: Nov 27 2017
Posts: 207

The dash display should have told about the bonnet unless you popped it up whilst fault finding. EKA is shown first.

Member
Joined: Oct 17 2016
Posts: 48

It looks like I may have a solution to the problem! When I bought the car the card with the EKA code was missing from the owners's manual. The seller told me that he believed the EKA was the same as the radio code which was written on the inside cover of the owner's manual. I phoned up my local Landrover dealer today and as it turns out the codes are not the same (they're very similar so I can understand why the guy I bought it from misremembered).

Member
Joined: Oct 17 2016
Posts: 48

And... it runs!

Member
Joined: Mar 22 2016
Posts: 1097

I’ve got both radio and eka on the back of the seat fusebox cover,, I came out yesterday to radio needing the code, god knows what happened

Member
Joined: Nov 27 2017
Posts: 207

no10chris wrote:

I’ve got both radio and eka on the back of the seat fusebox cover,, I came out yesterday to radio needing the code, god knows what happened

Its that time of the month Chris! :-)

Member
Joined: Mar 22 2016
Posts: 1097

mrabody wrote:

It looks like I may have a solution to the problem! When I bought the car the card with the EKA code was missing from the owners's manual. The seller told me that he believed the EKA was the same as the radio code which was written on the inside cover of the owner's manual. I phoned up my local Landrover dealer today and as it turns out the codes are not the same (they're very similar so I can understand why the guy I bought it from misremembered).

Did they give you the eka over the phone ? I’ve always had to go into dealers with logbook and enough ID to open any account I wanted, lol

Member
Joined: Oct 17 2016
Posts: 48

They gave me the EKA over the phone. It must be my dashing good looks.

Member
Joined: Mar 22 2016
Posts: 1097

Have you got there number, wouldn’t mind getting mine , I dropped the key about 2 months ago, had a no start situation, had to get a cab home, repair the key and cab back, grrr