rangerovers.pub
The only place for a coil spring is up Zebedee's arse.
Member
Joined: Jun 20 2017
Posts: 162

Hi all.
From the following discprition does this sound like my head unit is knackered. Doesn’t like to turn on but eventually does. Volume doesn’t alter and none of the buttons work. Seems to be worse in the cold. When it’s warmer works better but not always. This is the alpine unit in my 2002 Vogue SE. I want to keep the car original if possible.
Rob.

Member
Joined: Mar 22 2016
Posts: 1097

There is a place that repairs them, but I can’t find details at the minute, I’m sure someone will pipe up with them..

Member
Joined: Jun 20 2017
Posts: 162

I did find a place for repair but their website said that the alpine units couldn’t be repaired because of a parts supply issue.
Rob.

Member
Joined: Jan 16 2017
Posts: 480

Richard (Gillbertd) has posted about repairing them in the past, I think he was sending back to Alpine but did mention parts becoming an issue.

Member
Joined: Jun 20 2017
Posts: 162

Looks like I might have to get another unit. I really don’t want to move away from original.
Rob.

Member
avatar
Joined: Dec 30 2015
Posts: 3401

No not Alpine, Clarion will do the refurb treatment on the ones fitted to earlier cars but I don't know of anywhere that offer a similar service for the Alpine ones.

Member
Joined: Dec 29 2016
Posts: 209

I rang the Alpine Service Centre a few weeks ago about the head unit in our latest VSE.

They said I could send it in for a service/repair and they would decode it as part of that. They never mentioned they couldn't do it.

David.

Member
Joined: Jun 20 2017
Posts: 162

Hi David.
Do you know if the HU in our Vogue SE is different from other model P38s. Also do yo have the contact details of the Alpine service center.
Rob.

Member
Joined: Dec 29 2016
Posts: 209

I don't think it's different to the Vogue's... I've got one in my study that needs decoding. I'll get the part number off it in a bit so you can look.

https://www.alpine-service.co.uk/contact_us

I rang and spoke to a girl there who took the model number and quoted a price (can't remember what it was though I'm afraid).

David.

Member
Joined: Jun 20 2017
Posts: 162

Cheers David. There’s a few on eBay but don’t want to get the wrong one. I will call Alpine tomorrow and see what they say.

Member
Joined: Dec 29 2016
Posts: 209

The model number for the head unit in our Vogue SE is XQD101550LNF.

It's the same as the one in our other car too.

David.

Member
Joined: Jun 20 2017
Posts: 162

Thanks David much appricated.

Member
Joined: Dec 29 2016
Posts: 209

No worries :)

You're spurring me on to fix the audio issue in our original VSE, all the functions work perfectly apart from the speakers in both front doors...

Rear shelf speakers work, rear door speakers work, centre fill speaker works but there's nothing at all from either of the front doors.

Whilst the other car is awaiting it's engine I'll try swapping the amps and see if it's an amp fault or not before looking anywhere else.

David.

Member
Joined: Jun 20 2017
Posts: 162

I have been sorting my speakers as well. They all work but the bass speakers in the rear doors the foam surrounds had rotted away. I have replaced these. Passenger side front is rattling as well so that needs doing. Drivers side sounds good but will probably need doing. I have also just reformed the subwoofer cones. Just need to sort this head unit problem out.
Rob.

Member
avatar
Joined: Dec 30 2015
Posts: 3401

Bass speakers rusting so the cones can't move is a pretty common problem. One of mine was seized solid when I took them out to replace them with JBL units. Although there was still sound from that door from the mid range so it wasn't that noticeable until you turned the volume up.

Member
Joined: Jun 20 2017
Posts: 162

Just managed to buy one on eBay for £60 with code in excellent condition. Will see what happens when I put it in.