rangerovers.pub
The only place for a coil spring is up Zebedee's
Member
Joined: Oct 11 2020
Posts: 123

Hi a couple of weeks ago coming home I got a random 3 beeps but nothing showing wrong today going up hill sustained foot down again I got 3 beeps then nothing then 10 seconds later 3 beeps and something flashed on dash but was so fast couldn't read it and as gain nothing else wrong, I checked all the fluids when I got home except oil, letting engine cool but font see anything wrong, also the sounder behind dash doesn't always work so I'm not sure if this happens often or if I should be worried, apart from sunroof not working and few bulbs out it starts, drives, brakes gine with no overheating or other problems, TIA

Member
avatar
Joined: Dec 30 2015
Posts: 5212

I had that on the Ascot, 3 beeps, then another 3 beeps but nothing on the message centre. Then one day I got the 3 beeps and EAS Fault on the dash immediately followed by 3 beeps and it went off. At the same time the EAS height light went out then came back on. Problem was a dodgy connection in the multiway connector behind the LH kickpanel. Chopped the connector out and soldered and heatshrinked the wires.

Member
Joined: Oct 11 2020
Posts: 123

I've left car an hour then checked fluids there all fine except auto gearbox, I started engine run through gears nothing on dipstick so run through again and just below minimum erliwr after I got home it showed just over full and gearbox always seems to run fine so I put some fluid in I'm wondering if level was low and sustained up hill with foot down it got slightly hot, just not sure why erliwr it said slightly over full or why it's been fine running if low or if I've put to much in what damage could I do???

Member
avatar
Joined: Dec 30 2015
Posts: 5212

How much did you have to put in as it's only 200 ml from empty to full on the dipstick. So out of a full fill of 11 litres, a few millilitres is nothing.

Member
Joined: Oct 11 2020
Posts: 123

I dunno I put few capfulls in earlier but this time I cut a water bottle as a funnel maybe 50-70/80 ml in no much I cut the bottle at 45degree angle at label to spout and filled that let it drain then maybe another couple time so maybe dozen to 15 capfulls

Member
avatar
Joined: Dec 30 2015
Posts: 5212

I doubt it was gearbox overheat unless it did it just as you reached the top of the hill and came off the throttle so it cooled down immediately. You probably need to wait until the fault stays long enough for it to display on the message centre. Then you will at least know why it is beeping at you so can deal with that.

Member
Joined: Oct 11 2020
Posts: 123

Need to sort sounder so I know when it's doing/if it's doing it sounder used to work fine then resently it is hit and miss

Member
Joined: Oct 11 2020
Posts: 123

It still showed a bit low so I put more in and noticed 3 things, moving the gear selected is much smoother, it pulls off from stop much better and I have a ronbox fitted and before on setting 5 boost 3psi and off boost enrichment on I was getting warbling on idle when revving and its stopped now stick bit slow revs coming down but no warbling

Member
avatar
Joined: Jan 05 2016
Posts: 1097

I've had two gearbox overheat sensors fail like this on me - it's not a smart system as it literally goes open circuit as a thermostatic switch at a set temperature, but as they start to fail, they make/break randomly and this briefly triggers the warning. But it can be so quick - all you appear to get is the beeps and a very brief message flash.

Member
Joined: Oct 11 2020
Posts: 123

That was exactly it sloth beep beep beep then a pause then beep beep beep and error so quick hardly noticed it appearing on screen