rangerovers.pub
The only place for a coil spring is up Zebedee's arse
Member
Joined:
Posts: 26

Hi All,

Just installed a parrot system into the P38. The headunit was working fine before the install and now none of the buttons work + it is stuck on the last radio station and volume setting.

It isn't asking for a code, so I presume I doesn't need one?

Any ideas on what this could be? The parrot has been removed and the headunit remains in the same "locked" situation.

The parrot system seems to be working fine, plays music, answers calls etc.

Any help you be appreciated.

Tom

Member
avatar
Joined:
Posts: 5429

To add to this, as Tom has just left my place where the Parrot was fitted, the manual says to hold the UP button while turning the unit on. Doing that doesn't do anything but we both seem to recall that it has to be left for some time before it gets it's knickers untwisted. It was working perfectly, it was unpluggged and has been in this state since being plugged back in.

Member
Joined:
Posts: 26

Some added information from the drive home:

  1. The stero doesn't turn off
  2. There is feedback linked to the revs. Bad earth?
  3. When using the Bluetooth or accepting phone call there is a buzzing noise from the speakers like the volume is turned up very high
Member
Joined:
Posts: 26

Okay for the benefit of the forum. FYI My 2001 P38 has the alphine headunit. There was no radio lock code, however all the buttons went dead on the steering wheel and radio itself after installing the Parrot. I simply left the car overnight and in the morning it had reset itself and everything worked fine.

Hope this helps someone.

Tom