rangerovers.pub
The only place for a coil spring is up Zebedee's arse
Member
Joined:
Posts: 112

Evening all...

On the 99 I bought as a non runner I’m trying to see if it’s worth putting a few bits right to see if I can get it running. However, it’s got yellow Mayo in the oil cap and spout and the radiator overflow union is broken off, so I’m thinking it might have been abandoned due to a head gasket failure. What’s the quickest route to find out? I don’t really want to put a new rad on if it’s going to burst it or something.

It does start and run but I’ve not had it going long as it starts overflowing after 5 mins.

Tia

Member
Joined:
Posts: 257

You say it's a 1999 but what ---- V8 or diesel if V8 could be H/G or even a dropped liner

Member
Joined:
Posts: 325

My Disco had the yellow mayo in the oil. The fault was the timing cover gasket, not HG’s

Member
avatar
Joined:
Posts: 5902

Bleed the air out, plug up the hole and see if it starts to seriously pressurise. With the cooling system open it will overflow due to thermal expansion and probably an air lock. What does it run like when it is running? All 8 or does it misfire? Does it idle smoothly? Any tapping noises which would suggest a liner. Pull the plugs and do a compression test to see if any are down. Mayo may be front cover or may just be condensation due to lack of use.

This assumes it's a V8 and not an oil burner. If the latter I've no idea, never had anything to do with them.

Member
Joined:
Posts: 112

Thanks as always (you must be on here all day!!!)

It runs nicely for the few mins I’ve had it going. No misfire and sounds lovely and quiet. No tapping or anything.

The seller mentioned he recalled a mechanic saying radiator core being blocked. Is that likely?!

Member
Joined:
Posts: 112

And, 4.6 V8.... none of that derv muck...

(ducks for cover)

Member
Joined:
Posts: 257

The rads on Thor can block especially if got blue antifreeze and someone put pink antifreeze or vice versa as mixing them cause it to go like jelly ---- I would get rad and thermostat then see how it goes

Member
Joined:
Posts: 112

Hmmm interesting. I do have a spare new rad, will it be ruined if this engine is toast though?

Member
avatar
Joined:
Posts: 5902

j_rov wrote:

Thanks as always (you must be on here all day!!!)

Laptop is permanently logged in and I just refresh whenever I walk past it. Been a bit remiss today, been out to buy a kitchen for a Buy to Let we're buying, watched F1 qualifying, watched HRH Phil's funeral, went outside, masked up and finished painting a speedboat and now waiting for dinner to cook......

Try reverse flushing the rad and check the thermostat. It may well be clogged especially if, as Symes says, someone has mixed antifreeze types or put gloop in it for whatever reason (I've known people put K Seal in a cooling system when tightening a Jubilee clip would have stopped the leak). It has to be filled properly so there's no air in there or it will spit it all out.

And, 4.6 V8.... none of that derv muck...

(ducks for cover)

You can share my dugout if you like......

Member
Joined:
Posts: 257

Gilbertd. If you noticed at beginning of o/p it says rad outlet to expansion tank broke So waste of time reverse flush 👍 As for Derv only 1 to have is old 300tdi as runs on just about anything ---- not powerful but go on for miles & parts available anywhere in the world for it

Member
Joined:
Posts: 112

All academic now as my spare rad is for a Gems model!!!

£50 plus postage or collection if anyone wants it. Brand new in box, Bearmach.