rangerovers.pub
The only place for a coil spring is up Zebedee's arse
Member
Joined:
Posts: 519

simple question , can you bypass the O2 sensor system. i have 3 wrecks and none of them have O2 sensors , so can i bypass the O2 system on a 97 gems.

Member
Joined:
Posts: 634

I think you can run without O2 sensors. You’ll always be in open loop, running a tad richer than ideal, but no richer than a carbureted engine.

Member
avatar
Joined:
Posts: 7833

Not so sure. I fitted a 98 engine, complete with engine loom, into a 97 car. As the 97 and 98 use different O2 sensors the plugs were different so we left them disconnected thinking it would detect they weren't there and run a default fuelling strategy. Car fired up and ran normally but when taking it for a run, it adjusted the mixture so it got progressively weaker and weaker until it would no long run. The GEMS sensors are 5-0V Titania which give 0V when rich, so, thinking it was running very rich, it just kept leaning the mixture off. Rather than modify the looms, I made up 8 short lengths of cable with male and female connectors to connect them and it ran perfectly after that.

However, this was on a UK car intended to have the sensors so an Aus spec ECU may respond differently. Or, as long as you've got a Nano to use the security learn feature, fit the ECU from one of the cars without the sensors so it won't expect to see them.

Member
Joined:
Posts: 519

i understand where your coming from Richard , the cars i have are all 4.6L and mine is a 4.0l . I think i have another ecu in the shed that might be a 4.0l , will have a look . i have done some cross checking and have found that Subaru's have the same type off o2 sensors but i dont know if they are interchangeable thou. has anyone else looked at different replacements for the o2 sensors.

Member
avatar
Joined:
Posts: 7833

It doesn't matter, it's the same ECU for a 4.6 and a 4.0. You can change the engine size from 4.6 to 4.0 with a Nano.

Member
Joined:
Posts: 519

that's interesting for the ecu's , i thought they was a difference . i have just acquired another rover , this one is a running registered vehicle with EAS, so I'm just welcoming myself to the world of EAS issues now , fun. i haven't looked to see if this one has o2 sensors yet but i will and put the nano on and look for differences after the weekend thou.

Member
Joined:
Posts: 105

Definitely different V8 ECU's for each market. Presumably this is because they are programmed for zero, two or four O2 sensors ?

V8 ECU Part Number List

Member
Joined:
Posts: 519

hi Pete, i looked at the numbers but they don't say anything about the actual units other than their designation. on the ecu that i found in the shed it says that it's an 8.2 ECU , where the others are just 8 ECU . it doesn't make any reference to say it is with o2 sensors or not , i haven't found any info on them or any differences in them other than the year.
does anyone have an electrical diagram of an 02 05 Subaru forester that shows the o2 sensor pin out . the sensor are identical , even the 4 wires . if you are wondering why i am doing this it's simply the cost , the subaru ones are as cheap as $40 dollars compared to $250 dollars for genuine ones.

Member
avatar
Joined:
Posts: 7833

There are different programmed tunes for different years and vehicles which will also explain the different part numbers. The GEMS System document lists them, download from https://drive.google.com/file/d/1q_h1Cs5eTk550HgYUa2xz-rErBdZawjV/view?usp=share_link

Lambda sensors usually keep to the same wire colours, so if the wires on the Subaru sensor match those on the LR sensor (see at the bottom of this page https://www.lambdasensor.com/main/mcolours.htm) it will be a straight swap. You could also use that site to check that the recommended universal sensor for the Subaru is the same as the one for the P38.

Member
Joined:
Posts: 1345

As an aside (still on topic but off on a bit of a tangent)...

For some vehicles (don't know if this would be compatible with the RangeRover's none standard OBD) it's possible to fit an AEB OBDuFix (universal fix) to allow the engine to run without a lambda sensor when the fuel injection system expects a lambda sensor to be fitted.

These units connect to the lambda sensor signal wire and to OBD, they read the fuel trims via OBD and if the fuel trim goes positive they emulate a rich lambda reading which then steers the fuel trim back toward zero (or emulate a lean mixture lambda reading if the fuel trims go negative). In this way they constantly steer fuel trims toward zero whilst not upsetting the petrol ECU because it sees the constantly flicking lambda voltage it expects and fuel trims always stay close to zero.

https://www.aeb.it/en/products/emulators/obd-emulators/

They were designed for the purpose of preventing petrol fuel trims reaching extreme negative or positive when converting a closed loop petrol system to run on LPG using an open loop or standalone closed loop LPG system (such as a mixer system or an early standalone LPG injection system). Not necessary if fitting a 'slave' type LPG system which bases it's fuelling on would-be petrol fuelling. I haven't fitted one for many years but there was a time when we offered customers 2 ways of converting certain vehicles (e.g. 4L Jeeps), either a mixer system (standalone closed loop system so when running on LPG for a long time petrol fuel trims would eventually drift to one extreme) or a more expensive sequential slave type system (which avoided the problem if calibrated properly)... These units could prevent poor starting and harsh running on petrol (due to very wrong fuel trims messing the mixture up after a long period of running on LPG) and they were a must on post 2000 4L Jeeps because they'd put the MIL on which would disable the cruise control when fuel trims reached an extreme.

Usually fitted on vehicles that do have a lambda probe fitted (no need to address fuel trim issues if the vehicle doesn't have fuel trims because it doesn't have a closed loop fuel system / lambda probe), so they don't emulate the lambda probe heater circuit but that could be emulated with a simple dummy load (bulb etc?).

Member
Joined:
Posts: 519

so i have spent 2 days trying to find the right o2 sensor , have found some that are identical even with the right plug but they are 1v not 5v . todays o2 sensors are all 1v switching basically , where the rover is 5v switching with 4 wires . the cheapest 02 sensors that i found are at rimmers for $103 plus postage and vat tax make it $180 odd , so not really any cheaper . $50 dollars to post something that will fit in a small box is a bit rich . so i am now trying to find a second hand one .

Member
avatar
Joined:
Posts: 7833

How does this compare? http://www.ecolambda.co.uk/main/ecosale/price.pl?item=250-24804

Member
Joined:
Posts: 519

there's probably nothing wrong with them Richard, other than they don't ship outside the uk. the cheapest i found was rimmers but they charge you twice for postage so a $210 dollar purchase ends up being nearly $400 with tax and postage

Member
Joined:
Posts: 519

found a second hand one and replaced it and all is working fine once again
PS i also saw that if you soak the o2 sensor in liquid toilet cleaner it can revive them , so i will try that with the old one and see what happens.