rangerovers.pub
The only place for a coil spring is up Zebedee's arse.
Member
Joined: Feb 11 2018
Posts: 167

As above. Came up with electrical fault this morning and noticed that headlights are on permanent with ignition on. Also remote locking not working and side mirror not adjusting. Windows work fine.

No fuses blown.

I have a feeling it's the fusebox under the bonnet.

Engine starts fine.

Help please

Member
avatar
Joined: Jan 05 2016
Posts: 961

It is unlikely to be the fusebox under the bonnet as the headlights are fed from the BECM's outputs (which is, yes, fed from three maxi fuses in the engine bay fusebox).

So the headlights come on as you turn on the ignition, and go off again when the keys are removed? Does the dash and tell tale light up too?

Mirrors not adjusting is odd as the motors are driven by the door oustations, as are the front windows. So for one function to work and the other not is strange.

It may be requiring some TLC from Marty potentially.

Member
Joined: Feb 11 2018
Posts: 167

Yes the dash backlights come on as does the green headlight icon.

The cruise control, fog light and hazard light telltale don't come on. Not tried cc as in town.

Central Locking not working at all and key remote too.

Hevac seems fine.
EAS is fine too.

Just remembered, had the interior lights come up the other day. The message you get when disabling them.

Member
Joined: Feb 11 2018
Posts: 167

Wipers not working, front or rear.
Headlight main beam not working
Central locking not working
Interior lights not working including door lights etc.
No sound from cluster when indicators are used.
EAS self leved with door open (may not be related as door catch is not working correctly)

Member
Joined: Feb 11 2018
Posts: 167

There is also a burning smell in fusebox

Member
Joined: Feb 11 2018
Posts: 167

Ive reposted with better info

https://rangerovers.pub/topic/1525-becm-faulty