rangerovers.pub
The only place for a coil spring is up Zebedee's arse.
Member
Joined: Dec 30 2015
Posts: 1752

After the rolling code/EKA debacle this morning, my just drove it and locked it on the key as the fob wouldn't work. I was surprised as it has always synced in the ignition barrel until now without any further effort.
However, doing the door lock waggle, key press dance (I'm not quite sure what combo it was, but it worked) re-synced the fob.

On the basis that there's only so much "Character" I can put up with on a car, has anyone ever replaced the RF receiver ring thing in the ignition switch?

Member
Joined: Apr 23 2019
Posts: 328

Your car must be perfect if this is the one issue you are worried about :-))

Member
avatar
Joined: Dec 30 2015
Posts: 4028

If you've disabled passive immobilisation in the BeCM, it won't cause the fob to transmit when you put the key in the ignition so it won't do the easy sync.

Member
Joined: Dec 30 2015
Posts: 1752

She's not perfect, but the driver's door latch is already down one microswitch so we're not that far from being unable to sync a fob at all....
plus, it bugs me! :)

Richard, I'll double check but I think I've left it enabled. If it's me being thick again, great! hehe

Member
avatar
Joined: Dec 30 2015
Posts: 4028

Does the LED on the fob flash when you put the key in the ignition? If it doesn't, passive immobilisation is disabled (or the coil has failed.....).

Member
Joined: Dec 30 2015
Posts: 1752

Immobiliser was disabled! I'm assuming that's the same thing as Passive Immobilisation as it's the only one I can find.

On the other hand, the fob lost sync again tonight, within about an hour of being parked and without any little fingers this time. Batteries first I reckon.

Member
Joined: Jan 16 2017
Posts: 628

That is the right setting, Richard confirmed that in the thread with Frank after I asked

Member
Joined: Dec 30 2015
Posts: 1752

Thank you!
The good news is that SWMBO now knows the EKA off by heart :)