rangerovers.pub
The only place for a coil spring is up Zebedee's arse.
Member
Joined: Oct 09 2019
Posts: 7

Hi guys...I removed the subwoofer from my P38 and the rubbers have gone on each one. It's the standard HK but I can't find the output ? Any recommendations as to which speakers to buy ?? Thanks Dave

Member
Joined: Jan 07 2016
Posts: 145

Aloha Dave,
I have used 2 sets of these on both my 02s:

https://www.amazon.com/gp/product/B000CC3R8I/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1

The hole patterns match and they sound pretty good as well. A surprise for the price.
No holes on the back for the Sub amp to mount to (if you have the Premium system), but easy to work around that issue.
Cheers,
Tom

Member
avatar
Joined: Aug 10 2019
Posts: 13

I installed a set of these in my Callaway. https://www.parts-express.com/dayton-audio-dcs165-4-6-1-2-classic-subwoofer-4-ohm--295-198 Sound great.
I used a pair of Tangband drivers from the same outfit in my super end of year clearance "S type" 4.0 and they sounded surprisingly good for being a slightly smaller driver.

The Dayton's were a direct drop in fit. Holes lined up, size was perfect. Sorry but the Tangbands were so long ago that I can't retrieve the info for them but I did have to
make small adaptor rings to mount and properly seal them.

A word of note. I pulled my passenger door card the other day to replace my latch assembly and discovered that the surrounds were disintegrated on the midrange
driver. From experience, I don't need to look to know the other three are bad as well so in my search to find a reasonably priced mid I purchased two pairs of these
https://www.crutchfield.com/p_108R3032CM/Infinity-Reference-REF-3032cfx.html?cc=07 Can't tell you how they sound yet as I'm still waiting delivery on both the speakers and the door latch from LRD.

Member
Joined: Jan 16 2016
Posts: 323

I replaced the rubbers on my speakers a year or two ago. Not something I would recommend doing again though.
They had to be cut to fit then glued in place. They worked for a bit but the amp has now gone kaput.
Fixing the subwoofer is on my list of lockdown jobs. I am hoping it is just something simple like a fuse or wrong settings on my head unit.
I could do with a cheap signal injector to trace the problem. Any recommendations guys? I mean really really cheap.

Member
Joined: Dec 30 2015
Posts: 1140

I replaced the foam surrounds that were on my subwoofer speakers... bought a pair of generic 6.5" foam surrounds and the speaker glue to fit them.

Pretty easy job - I had to use a couple of bulldog clips to get the inner part to stay sticking to the cone as it the glue was setting, but once it had stuck, the outer rings were easy.

So far so good, and they're working again.

Dave3d - first check LHF footwell kick panel connectors - the subwoofer feed wires from the head unit run through those connectors, (Orange and Orange/Black wires). So if you haven't cut them out already, then it might be worth a look, as I cut a set out and soldered the wires together for another owner (to fix a different issue) and he said afterwards that the sub suddenly started working again... realised afterward that the sub went through there :)

Member
Joined: Feb 25 2020
Posts: 100

On the topic of the subwoofer, do I risk frying everything if I run an aftermarket amp using the power wires from the original HK amp? I ditched the original HU setup and after fitting the attenuators, I am now running cabling for the sub - will keep the original HK sub (obviously with new drivers, mine were beyond shot), but with a Blaukpunkt GTA270DSP, 200W RMS in mono at 4ohm, 20A fuse, but asks for minimum section 6mm2?
In case the original setup is not feasible, can I splice into the rear left power (the one for the tow hitch) or better run directly something from the front (more wires!)?

Member
Joined: Dec 29 2016
Posts: 306

I replaced mine last weekend. Have a look at my post on this thread:

https://rangerovers.pub/topic/503?page=7

I used these speakers in mine and can't fault them:

https://www.thompsonsltd.co.uk/brands/maxp64-lanzar-maxp64-max-pro-6.5-600w-small-enclosure-4-ohm-subwoofer-(single).html

David.

Member
avatar
Joined: Aug 10 2019
Posts: 13

I've just about stopped replacing surrounds in drivers. It's really far too tedious to do.
You have to be certain the voice coil that is mounted to the driver cone stays absolutely centered within the tiny air gap between it and the magnet that drives it.
If your very careful and you check it frequently the spider will generally keep it centered. I have always done the inside surround to cone gluing first then
after that is dried you can glue the outer surround to the frame and evenly and gently weigh down the very center of the driver without deforming the dust cap until dry.
If this air gap is not maintained the voice coil will rub against the magnet wearing off the varnish insulation and shorting it out.
Could be that's what happened to your amp.