rangerovers.pub
The only place for a coil spring is up Zebedee's
Member
Joined: Oct 11 2020
Posts: 123

Hi perps hopefully this is a quick 1 other day I did tests on drivers seat but wasn't sure what readings ment so I did bit more reading and today while taking kids to school I put seats on but kept quiet, eldest said after 5 mins did seat have heaters because his back as nd bum were getting warm and he didn't like it but when I put hand on seat I couldn't feel anything, so when I hot home I left heaters on but disconnected plugs to both seats and readings I got were as follows i got 14.65v passengers plug from car and 14.7v drivers plug and plug from seats I got continuity passengers seat of 0.61 small plug and 0.6 large plug but drivers side was 0.56 large plug and nothing on small plug at all so does that mean a break on drivers seat in back part of seat?

Member
avatar
Joined: Dec 30 2015
Posts: 5213

Yes. The two elements are in series so if one is open circuit that seat won't work. If it is the backrest that is open circuit that is usually the easy fix, the wires break where the normal wire joins the end of the element at the base of the backrest. You'll need to take the seat out to solder it though.

Member
Joined: Oct 11 2020
Posts: 123

I disconnected small plug and bridged the small plug car side to complete circuit and base got warm in less than 2 mins so it's deffinatly rear and can wires been seen?

Member
avatar
Joined: Dec 30 2015
Posts: 5213

They can be seen if you recline the seat fully so it is almost flat.

Member
Joined: Oct 11 2020
Posts: 123

Thanks bud can it be repaired in situ or does seat still need split

Member
avatar
Joined: Dec 30 2015
Posts: 5213

Seat needs to come out, reclined fully so it lays flat and you should be able to see where the break is on one side without separating the two parts.

Member
Joined: Oct 11 2020
Posts: 123

When I was at school getting kids I reclined seat fully and 2 parts so tight together could hardly get ringures in bud let alone see anything

Member
avatar
Joined: Dec 30 2015
Posts: 5213

You've got to take the seat out first......

Member
Joined: Oct 11 2020
Posts: 123

OK bud, I don't know if I need kit from Internet or just soldering gun and some cable

Member
avatar
Joined: Dec 30 2015
Posts: 5213

Soldering iron, solder, bit of flexible wire and heatshrink tubing.

Member
Joined: Oct 11 2020
Posts: 123

Thing is if I check continuity in the small plug like I do with big plug then it shows nothing so is that the circuit between to parts that's buggered is there a break in element itself

Member
avatar
Joined: Dec 30 2015
Posts: 5213

Testing open circuit means that there's a break. Usually if that's what you get when testing the base, it's a break, or more likely breaks, in the element. If you get that when testing the backrest, it's usually a break where the wiring connects to the element.

Member
Joined: Oct 11 2020
Posts: 123

Thanks bud I'll see what I can see later

Member
Joined: Oct 11 2020
Posts: 123

never got far with seat today but if i recline it fully back i canot even get fingures between base and backrest let alone see broken cables, im assuming plastics will have to come off and undo backrest?

Member
avatar
Joined: Dec 30 2015
Posts: 5213

Plastics? But they will be off when you've taken the seat out. There's a flat of material between the backrest and base that is clipped on, if you lever that long plastic clip then you can separate the two halves. There's no need to take the backrest off though.

Member
Joined: Oct 11 2020
Posts: 123

so basically its under the flap

Member
Joined: Oct 11 2020
Posts: 123

OK I took a quick look I can see the long black clip that is hooked onto base and 2 hog rings it is loose at side nearest door which is side cable goes to do I had a look and a feel and the cable hoes tight round into mback part of seat would that be a likely place because feeling the sleeve it feels hollow

Member
Joined: Oct 11 2020
Posts: 123

OK I had seat out and at the base of the backrest is black plastic but it is glued to flap on seat base as well I removed plastics and undid the backrest on side furthest from armrest were there was black and yellow cables they all seem well attached and no obvious damage so I'm beginning to thing its the element or something deeper inside seat at fault