rangerovers.pub
The only place for a coil spring is up Zebedee's arse
Member
Joined:
Posts: 151

I am trying to sort out why there isn't a power supply working at my tow socket for the R/H indicator

It has the Euro multi pin socket. R/H indicator works on the car but not at the socket.

It seems that the correct wire at the car is a blue feed which is dead at the socket.

Just wondering, are the trailer indicators fused separately?

If so, where will I find the fuse?

If not, where is this blue wire fed from? All connections in the socket are sound, no corrosion so.......

Thanks in advance........

Member
avatar
Joined:
Posts: 5817

No additional fuses for the trailer socket. Assuming it has the factory trailer socket fitted and not an aftermarket one, Blue wire goes to pin 2 and is the rear fog light feed, RH indicator is Green on pin 4. That is for the UK standard 7 pin socket, if you have one of the 12 pin ones, the colours will be the same but the pin numbers won't be. They wiring from the trailer socket connects to a socket that dangles behind the RH rear light cluster. It's a white 6 way connector where the feed coming in for the RH indicator is on a Green/Yellow wire which changes to Green at that point before disappearing through a grommet in the floor of the car. There is likely to be another connector, a Supaseal one, under the car before the wiring gets to the socket itself.

Member
Joined:
Posts: 151

Thanks for that! Very useful info.

Mug of tea in hand and back outside......

Member
Joined:
Posts: 151

All wiring checked and tightened, all OK

Swapped for another adapter and all Hokey Cokey!

Thanks for your help :) Thought I was going mad......