rangerovers.pub
The only place for a coil spring is up Zebedee's arse
Member
Joined:
Posts: 96

I thought I would make my own thread following on from the few posts in the "exhaust manifold flexis" thread where I was trying to find the source of a metallic ticking sound in my engine.

To reiterate the problem is a ticking sound that I can hear which appears to be coming from the right side of the engine. It's related to engine load rather than RPM - for example if I'm traveling up a hill with the torque converter locked pressing the throttle more will make the ticking sound louder without the RPM changing. This is why I originally thought it was an exhaust leak.

Here's two videos:

Here's the things I've tried so far:

  • Listened around the manifold area using a hose - couldn't hear any leaks.
  • Smoke tested the exhaust - no leaks found.
  • Checked the CPS reluctor ring teeth and flex plate - nothing found.

I can't understand how it would get louder with more engine load without it being an exhaust leak.

Any other suggestions would be appreciated? It's driving me mad not being able to find it 😃

Member
Joined:
Posts: 74

Loose spark plug perhaps?
Head gasket going perhaps?
I'm a diesel guy but a head gasket going on my Defender made a ticking noise as did an injector seal washer and a leaky exhaust manifold gasket.

Member
Joined:
Posts: 457

I’ve previously had 2 V8’s (not LR) that have had ticking like I think you’re describing. In both cases snugging up the exhaust manifold bolts cured the tick. I’m not sure if I would have been able to pinpoint the leaks with a hose or not. Good luck on it.

Member
Joined:
Posts: 223

my 4.2 V8 supercharger sport has a ticking sound under load it the exhaust manifold gasket got a leak

Member
Joined:
Posts: 202

I had a crack in the flexi on the exhaust manifold which gave symptoms like you said. I couldn't see it until removed from the vehicle and bent open.

But i have a new tick on the other side now which I think is a push rod/tappet gap as only on idle/overrun and goes away with revs.

Member
Joined:
Posts: 356

Am currently working on a 3.9 engine that made that noise ----- turns out lifters on right bank sized up and worn on cam face Push rods worn and cups of rockers worn Also cam lobes on inlet(3,5,7 worn down on peaks Yet left bank all fine ---- Hopefully yours not same ---- 3.9 basically same as 4/4.6 as far as valve train is