rangerovers.pub
The only place for a coil spring is up Zebedee's
Member
avatar
Joined: Dec 30 2015
Posts: 5214

Some are worse than others but when you spend £25 on a rebuild kit only to find bolts shear off so you have to spend £75 on a new reducer, you may as well have saved the £25. It's not like a new reducer is expensive anyway.

Member
Joined: Dec 29 2016
Posts: 452

Today was spent tidying up the LPG installation.

The ECU has been moved to the slot behind the battery where the GEMS ECU usually lives. Thankfully, on a THOR car this is an empty space.

As I've moved the ECU some of the cables weren't long enough, as I've moved the reducer I had to reroute the temperature sensor as it was on the other side of the car with the safety solenoid and there was so much excess wiring that it was driving me nuts so I've cut a load of it out and remade it with new wires, some braiding and a ton of heat-shrink.

I was going to run a new gas supply pipe up from the tank to the drivers side of the car where I've mounted the new reducer but instead I've left the safety solenoid on the near side and have relocated the reducer to the drivers side to keep the house run to a minimum as the old hoses used to run across the bulkhead and it looked a mess.

The copper pipe we've got has a white plastic surround on it which is driving me nuts as it stands out like a sore thumb. Unfortunately the LPG Shop online were out of stock of the black coated stuff when we ordered which was annoying.

Anyway, I'm going to finish connecting the LPG back up tomorrow and if I get time, I'm hoping the engine will be back on it's mounts too!

I spent ages feeding the cables through black braiding and then put heat shrink on the ends.

enter image description here

I shortened 2 metres off the plug for the reducer temperature sensor and tidied that up too.

enter image description here

The cables going from the LPG ECU to the engine ECU weren't long enough after moving the LPG ECU so I made a new loom for them. The existing connections onto the Engine ECU were twisted around the cable, soldered and then taped over. I removed the pins from the plug on the engine ECU today, remade the connections and slide some heat shrink over them rather then using tape.

enter image description here

enter image description here

enter image description here

Both of the new braided looms fit into the existing clips on the bulkhead which is nice as it keeps it tidy and it almost looks original.

enter image description here

enter image description here

After reading online, it turns out the new reducer can be mounted vertically or horizontally which was handy as it fits really well on it's side beside the brake accumulator.

enter image description here

enter image description here

enter image description here

Finally feels like I've made some progress today!

David.

Member
Joined: Dec 29 2016
Posts: 452

On another note, does anybody know what is directly behind the bulkhead? Could you safely put tech screws through there to secure a gas pipe?

Member
avatar
Joined: Jun 17 2018
Posts: 786

That reducer looks well "bling" blends in well!!

Can't wait to see a V8 in that space.

Member
avatar
Joined: Dec 30 2015
Posts: 5214

See what you mean about the white sheathed pipe, I've never even seen white sheathed pipe, I thought it only ever came in black anyway. It's only a short length so it should be fairly easy to replace it (or unhook it at one end and but some of the black braiding over it). I had to make a complete wiring loom for one car and used miles of that braiding, wonderful stuff and looks really professional.

Member
Joined: Dec 29 2016
Posts: 452

It's in...

enter image description here

enter image description here

enter image description here

I'm going to get as much as I can buttoned up tomorrow but a lot of the things I've ordered still haven't arrived. The LPG is finished, the pipework, solenoid and reducer are all finished and the new gas pipe for the injectors has arrived. Although the gas supply pipe and inline filters hasn't arrived yet.

I'm still waiting for my Magnecor KV85's, MAF, Thermostat, and a few little odds and sods to arrive so it won't be running tomorrow. With a bit of luck they'll be here before the end of the week as it'd be really nice to see it finished now I've finally managed to get some momentum going.

David.

Member
avatar
Joined: Jun 17 2018
Posts: 786

Nice Job!

That 4.6 is gonna be a stormer i bet!

My 4.6's get up and go has got up and left LOL

love the VSE can't wait to see it going under its own power!

Member
Joined: Dec 29 2016
Posts: 452

With lockdown I started doing work on the other one whilst I was waiting for parts to arrive so having 2 of them "In Progress" at once is challenging! Just as I thought the other one was finished I started to get niggles again. Hey ho, we'll get there!

Member
Joined: Dec 29 2016
Posts: 452

A bit more was done on both cars today. The engine is just about finished in this car now. I've got to fit plug leads (when they arrive...) and then refit the coolant system and radiator. It's getting all new hoses and a new radiator whilst I'm in there so with a bit of luck it'll all go back together quite nicely.

The wiring loom has all been routed and connected to everything underneath the car. I'm glad I had another one here to reference as it's 15 months since I took the engine out of this car so daft things like trying to remove just how the wiring loom is routed across the top was handy. Thankfully the bits I needed to check were easy to check without having to do any dismantling on the other day.

enter image description here

enter image description here

enter image description here

I hadn't realised how battered that belt cover was so I've ordered another one of them this evening.

David.

Member
Joined: Dec 29 2016
Posts: 452

Well, yesterday the Magnecors arrived and were dually fitted.

enter image description here

I ordered a Britpart hose set for it against my better judgement... Most of it has ended up in the bin other then a couple of bits that looked scruffy on our originals. Whoever in Britpart thinks this is acceptable for a top hose needs shot...

enter image description here

enter image description here

I managed to get the rest of the car buttoned back up and finished off yesterday too. It was filled with coolant, the oil filter was filled with oil and fitted to the engine, the oil that was supplied by V8 Developments was poured in along with the additive for the camshaft and everything was given a final once over.

I don't like the route of the original gas pipes and they're not long enough to reroute properly so I've bunged a bolt down each of them for now to make sure they're sealed until the new pipe I've ordered turns up and I can replace them all.

We tried to start it last night and it turned over and showed no signs of life. I didn't spin it much as I was concerned about the new cam so I left it until this morning. As soon as I walked into my house from the workshop it hit me that I hadn't reconnected the crankshaft sensor. I plugged it in this morning, had my Dad climb in, he pressed the accelerator to get it half open and cranked her over and she burst straight into life.

I set a timer on my phone for 10 minutes and he sat with the revs held steady at 2500rpm.

As he was keeping an eye on the revs and the temperature gauge I was crawling over the engine above and below checking for leaks as well as checking there was a return to the coolant bottle from the radiator. After 7 minutes had passed the temperature gauge fell from the middle to the blue so Dad killed the engine. I let it cool down, checked the levels, topped the coolant up slightly and went for round 2...

I set a timer on my phone for 15 minutes this time. We cranked her over and she burst straight into life and sat at 2500rpm.

Whilst sitting at 2500rpm for the 2nd time I was checking for leaks, making sure all of the hoses were getting warm, and using an IR thermometer looking for any part of it that was much hotter then the rest. We got the 15 minutes done with no issues at all so the camshaft is now bedded in as per the advice we were given from V8 Developments.

Annoyingly on the 2nd run the temperature gauge on the dash didn't go above the blue. It looks like the new Britpart temperature sensor I fitted has lasted for a whole 8 minutes of running. I'm going to remove it tomorrow and refit the original and see if it's any better.

Anyway, she's in, she's running beautifully and everything seems happy...

Video - https://imgur.com/J5dYZsL
(There's noises in the video that I can't hear when it's running so it sounds worse then it is!)

I've since taken all of the scuttle panel under the windscreen off to clean under it and refit the foam so keep all of the crap out. I also spent a few minutes tidying up various surfaces under the bonnet too.

enter image description here

New hoses are ordered to tidy this up a bit too...

enter image description here

enter image description here

enter image description here

So... 15 months after it started this topic can finally draw to a close!

Member
Joined: Dec 29 2016
Posts: 452

And we now have an MOT :)

The new engine must be in fine fettle as it barely registered on the emissions. It drove really well for the 10 miles each way to it's test also.

I got 2 advisories. The ferrule on the front left and front right brake flexi are corroded. Apparently they're nowhere near bad enough to need replacing but he's given me an advisory. Other then that, he said it was a very solid car underneath.

Time to get it taxed and start using it!

David.

Member
avatar
Joined: Dec 30 2015
Posts: 5214

I've never seen any that aren't corroded, it just depends how keen the tester is to put something on advice. The guy that tested the Ascot said that it looks suspicious if they pass a 20+ year old car with no advisories, it makes VOSA think they aren't doing the test properly.

Should you decide to replace the hoses though, these https://www.merlinmotorsport.co.uk/s/goodridge/goodridge-brake-hose-kits/brake-hose-kits-car/range-rover are a good deal for a full set. Or you can buy the ends and a length of hose and make them up https://www.merlinmotorsport.co.uk/s/goodridge/goodridge-600-series-brake-clutch-hose-fittings, I had to do that recently for new hoses for the Maserati I'm in the process of putting back on the road. Brake hoses, something I would have regarded as almost a service item, are no longer available????

Member
Joined: Dec 29 2016
Posts: 452

Cheers Gilbert.

Genuine LR ones are around £20 each or you can buy a set of AllMakes ones on eBay for £39.99 for all 4. I'll get it back on the ramp when I've got the other VSE off it and see how bad they are.

David.

Member
avatar
Joined: Dec 30 2015
Posts: 5214

They have 6, post 97 there's two short ones on each side at the back, the earlier ones have a short one on each side and two longer ones in the centre. Buying the fittings and a length of Goodridge hose works out more expensive than buying the full set.

Member
Joined: Sep 14 2016
Posts: 520

I wonder if the Venhill system having simple pipe thread free nut unions on the ends of the hoses with separate screw on connectors to mate with the brake caliper or whatever has any advantages for car work. Seems logical and a bit more flexible, especially if its something where you can't get them off the shelf. Prices seem much the same as the usual Goodridge et al one piece types.

I've done Goodridge myself before back when made to fit was either not available or horrendously costly. Still have all the tooling but I can do without being poked by sharp ends of stainless braid.

Clive

Member
avatar
Joined: Jun 17 2018
Posts: 786

Got any "complete pictures" David ;)

Member
Joined: Dec 29 2016
Posts: 452

Err... good question... I'll have a look through my phone shortly.

Need to finish the LPG off and get the injector pipes finished before I'll grab some properly finished pictures! At the moment they've got bolts in them to stop the vacuum leaks!

David.

Member
avatar
Joined: Jun 17 2018
Posts: 786

How's it going David?

Hows the motor?

Member
Joined: Dec 29 2016
Posts: 452

So far so good. It's not done 200 miles yet though as we're just not going out much.

Comparing it back to back with mine it's quicker and smoother but V8 Developments advised not to go over 4000rpm for the first 1000 miles so I've been behaving with it.

The other car is being a royal pain in the arse at the moment with suspension issues so it's taking my time at the moment.

David.

Member
avatar
Joined: Jun 17 2018
Posts: 786

Nice to hear the new engine is performing well..

Hows does she compare to your other VSE?

Any........................................................

Cough....

Pictures lol