rangerovers.pub
The only place for a coil spring is up Zebedee's arse.
Member
Joined: Oct 09 2019
Posts: 5

Hi I have recently purchased a 1998 4.6 ...neither the sunroof or trip computer work.

I have been told it is very likely they have been omitted from the BeCM as more than likely their is a sunroof fault. I intended to fix it and a new switch pack has failed to solve it. It does not flash up sunroof not set or similar so this would seem likely..

Dies anyone in the Manchester area have a nano Comms that could check...beer and crisps provided in payment...any takers please ?? Best wishes Dave

Member
Joined: Apr 23 2019
Posts: 264

Welcome Dave

Member
avatar
Joined: Dec 30 2015
Posts: 3835

Hi Dave, glad you found your way here. I think we have at least 2 Nanocom owners in the Cheshire area who should be able to plug in and check the settings.

Member
Joined: Jan 07 2016
Posts: 102

Aloha Dave,
Welcome to the Pub! You have found out where Richard lives when he is not Gilbert! Oh, and where correct info now lives as well!
Saw your posts on the Dark Side, and glad you made it here. Over there, you have no way of telling where anyone is anymore, so no surprise you found no takers. Sounds like you are on the correct track.
Good luck!

Member
Joined: Oct 09 2019
Posts: 5

Thanks guys it's appreciated.. hopefully a kind member will help me out soon 😁

Member
Joined: Dec 30 2015
Posts: 1099

If it is saying "sunroof not set" when you press the buttons for the sunroof, then it is turned on in the BECM. If it is turned off, then any input from the sunroof switches are ignored.

It's probably worth unplugging the sunroof motor and seeing if 12v gets to it when the button is pressed. Will tell if it's an issue with it getting power, or whether the motor is faulty.

If it doesn't come up Sunroof Not Set, then it could have been turned off - but it could have been done because there is a fault in the sunroof itself (more than likely a broken runner) - but you won't find that out until you try it!

Trip computer is a BECM setting aswell that just might not have been enabled on yours.

Member
Joined: Oct 09 2019
Posts: 5

Thanks that's great...I think the first option is to plug it in and see what comes up on diagnostics...thanks again Dave

Member
Joined: Apr 23 2019
Posts: 264

I note no diagnostics offers for you yet, Dave. Let me bid SW London, near LHR, I'm sure someone can better that though.

Member
avatar
Joined: Dec 30 2015
Posts: 3835

I'm sure there's at least two members up in that neck of the woods but can't for the life of me think who they are...... I'm a bit closer than Rob but not by much.

Member
Joined: Jan 15 2016
Posts: 378

I used to be. But that's not particularly helpful!

Hope someone steps up.

Member
Joined: Jan 16 2017
Posts: 573

I've got a Nanocom with the p38 bits added on it (Green lead and the p38 systems unlock code), Closest I can do is Belper area if thats any help, but it won't be immediately as would be a case of taking it to my mates place and meeting you there. May end up closer with work if your not in too much of a Hurry. Or if your near Milton Keynes area at any point?

Have got only the Thor engine bits loaded on it for p38 though. No GEMS or EDC at this time.

Member
Joined: Dec 30 2015
Posts: 1654

Davemilner wrote:

Thanks guys it's appreciated.. hopefully a kind member will help me out soon 😁

Well, I'm closer than Heathrow!!! Malton YO17 but that's still the wrong side of the Pennines... I'm in this weekend if you fancy a trip!

Member
Joined: Jan 16 2016
Posts: 238

I am half way between Northwich and Chester. I have a Faultmate, not a Nanocom.
I can read your BECM and let you know what the settings are. If necessary turn things on.